Grundlagen zu Tabellenkalkulation

aus ZUM-Wiki, dem Wiki für Lehr- und Lerninhalte auf ZUM.de
Wechseln zu: Navigation, Suche

Herzlich Willkommen zu meiner Selbstlerneinheit zum Thema Grundlagen der Tabellenkalkulation.
In insgesamt zwei Kapiteln möchte ich dir grundlegendes Wissen zum Thema Tabellenkalkulation beibringen mit dem du abschließend sogar das Spiel Tic Tac Toe eigenständig umsetzen kannst. Und falls es doch Schwierigkeiten geben sollte, steht ein Hilfevideo in Kapitel 3 zur Verfügung.
Es gibt viele verschiedene Tabellenkalkulationen, wie zum Beispiel die von LibreOffice, OpenOffice oder Microsoft Office. Ich beschränke mich bei meiner Selbstlerneinheit auf Excel, allerdings sind die Sachen, die ich erkläre so grundlegend, dass sie bei allen Tabellenkalkulationen gleichermaßen funktionieren. Ich wünsche dir viel Spaß!

Inhaltsverzeichnis

Einstieg:

Los geht´s: Die ersten Begriffe

In diesem ersten Abschnitt möchte ich dir erklären, wie man eine einfache Tabelle in Excel erstellt. Am Ende dieses Abschnittes solltest du folgendes verstanden haben:

  • Du weißt, was der Unterschied zwischen einer Spalte und einer Zeile ist.
  • Du weißt, was eine Zelle ist und kannst sie konkret benennen.
  • Du weißt, wie man eine Tabelle erstellt und wieder ausliest.

Falls du das schon kannst, springe zum nächsten Kapitel. Doch keine Angst, wenn du gerade nur Bahnhof verstehst! Die folgenden Abschnitte werden dir schon helfen. Also los geht's!

Spalte, Zeile, Zelle. Was ist das überhaupt?

Wenn du dir das folgende Bild anschaust, dann siehst du verdammt viele kleine Kästchen. Doch wie bekommt man denn da eine Struktur rein? Damit meine ich: Wie kann man einem Anderen sagen, in welchem Kästchen z.B. eine Zahl steht wie zum Beispiel die Zahl 87.

Unterschied Spalte und Zeile verstehen

Dafür hat man sich überlegt, dass jedes Kästchen einen Namen bekommt. Übrigens: Statt Kästchen sagt man "Zelle".
Damit du aber verstehst was der Name bedeutet, musst du erst noch zwei neue Begriffe lernen: Die Zeile und die Spalte.
Am linken Rand dieser vielen Kästchen siehst du links Zahlen (im Bild rot markiert) von 1 bis 33 und oben Buchstaben von A bis U (im Bild blau markiert). Zu einer Spalte gehören nun alle Kästchen, die unterhalb eines Buchstaben sind. Als Beispiel habe ich dir mal die Spalte "G" mit gelb markiert. Zu einer Zeile gehören alle Kästchen, die rechts neben einer Zahl angeordnet sind. Als Beispiel könntest du die Zeile "11" betrachten. Auch diese habe ich dir einmal mit der Farbe grün markiert. Puh, das klingt aber alles sehr theoretisch! Schauen wir uns mal das folgende Bild an:

Lageplan einer Klasse

Stell dir vor, du möchtest deinem besten Freund erzählen, auf welchem Platz du in diesem Raum sitzt (hier mit einem roten Kreuz markiert). Das ist doch ganz einfach, oder? Du könntest ihm sagen, du sitzt in der ersten Reihe ganz links.
Deine Aufgabe: Probiere deinen Sitzplatz zu beschreiben, indem du die Zeile und die Spalte in der du sitzt, nennst.

Die Lösung ist "A1"!

Die Lösung siehst du, wenn du für ein bis zwei Sekunden mit der Maus über dem obigen Bild stehen bleibst.

Genau so wie du gerade beschrieben hast wo du sitzt, kannst du auch den "Sitzplatz" einer Zelle erklären. Dafür musst du nur angeben, in welcher Zeile und in welcher Spalte sich die Zelle befindet. Ein Beispiel: Die Zelle in der C-ten Spalte und fünften Zeile nennt man "C5". Die Zahl 87 aus dem obigen Bild befindet sich in Zelle "D11". Wenn du dir jetzt sicher bist, dass du eine Zelle benennen kannst, dann bist du bereit für den nächsten Schritt.

Ordnung in Informationen bringen: Unsere erste Tabelle

Unsere "Theoriephase" ist vorbei und wir können uns nun der Praxis widmen. In diesem Abschnitt möchte ich dir eine erste Anwendung von Excel näher bringen: Die Verwaltung von Daten.
Sicherlich hast du schon einmal eine Klassenliste gesehen, in der jeder Schüler der Klasse mit Vor- und Nachnamen und Adresse eingetragen ist. Wir wollen nun selbst so eine Liste erstellen, allerdings wollen wir nicht nur den Namen und die Adresse einfügen, sondern auch die Telefonnummer und das Lieblingsfach.

Doch wie macht man so etwas genau? Wie schreibe ich solche Informationen am besten auf? Hierfür habe ich dir eine Übung vorbereitet.
Versuche alle Einträge unten den Begriffen oben zuzuordnen.

Vorname Christopher Lisa Thomas
Nachname Müller Schmidt Schneider
Wohnort München Berlin Heidelberg
Telefonnummer 06221/23041091 06621/230909003 06221/2313910477
Lieblingsfach Mathematik Deutsch Sport

Du hast gerade eine Menge von Informationen bestimmten Oberbegriffen zugeordnet. Hinter den vielen einzelnen Begriffen stecken die Daten von drei Personen:

  • Thomas Müller aus Heidelberg, Lieblingsfach: Mathematik, Telefonnummer: 06221/2313910477
  • Lisa Schmidt aus München, Lieblingsfach: Deutsch, Telefonnummer: 06221/230909003
  • Christopher Schneider aus Berlin, Lieblingsfach: Sport, Telefonnummer: 06221/23041091

Hättest du diese Daten vorher gehabt, hättest du dann deine Zuordnung zu den Begriffen verändert? Sicherlich nicht, denn deine Aufgabe war es ja nur z.B. alle Vornamen in den Kasten Vornamen zu ziehen. Doch kann man nach der Zuordnung noch feststellen, ob Christopher mit Nachnamen Müller, Schmidt oder Schneider heißt? Leider nicht. Man hätte allerdings nach und nach die Personen mit Vorname, Nachname, Wohnort, Telefonnummer und Lieblingsfach einfügen können. Das hätte den Vorteil gehabt, dass der erste Begriff in jeder Gruppe zur ersten Person, der zweite Begriff zur zweiten Person und der dritte Begriff zur dritten Person gehört. Hätte man nun wissen wollen, wie der Nachname von Christopher ist, so hätte man nur schauen müssen an welcher Stelle der Vorname Christopher steht und diese Stelle bei der Art der Information, also dem Nachnamen, ablesen können.Und genau das ist die Idee einer Tabelle.

Sortieren von Daten/Sinn der Tabelle verstehen

Zur Umsetzung in Excel: Du kannst nun in eine Spalte "Vorname" schreiben und darunter alle Vornamen einfügen, die in der Liste vorkommen sollen. Danach schreibst du in die Spalte daneben "Nachname" und fügst darunter die Nachnamen ein. Wichtig dabei ist, dass du das nicht willkürlich machst, sondern neben den Vornamen den dazu passenden Nachnamen schreibst, denn du willst die Tabelle später ja noch einmal auslesen können. Alle Informationen, die im obigen Bild miteinander verbunden sind gehören also in die selbe Zeile, denn sie gehören zu einer Person. In einer Zeile stehen also immer die Informationen zu einer Person, die Spalten geben an, um welche "Art" von Information es sich handelt. "Vorname" gibt zum Beispiel an, dass alle Informationen darunter ein Vorname sind. Unsere Tabelle sieht dann so aus :

Eine erste Beispieltabelle einer Klassenliste.

In der Zeile 7 stehen alle Informationen über Thomas Müller, in Zeile 8 die von Lisa Schmidt und in Zeile 9 die von Christopher Schneider. Übrigens: Das ist nur ein Beispiel. Du könntest auch die komplette Tabelle in der Zelle A1 beginnen lassen. Nun solltest du die Struktur einer Tabelle verstanden haben und gerüstet sein, deine eigene Klassenliste zu erstellen.

Mit Formeln arbeiten:

Einzelne Zellen automatisch einen Wert errechnen lassen

Stell dir vor du arbeitest in einem Supermarkt, indem es keine hochmodernen Kassensysteme gibt. Damit du aber nicht alle Kassenzettel per Hand schreiben musst, hat dir dein Chef einen Computer zur Verfügung gestellt, auf dem du Excel vorfindest. Ein Kassenzettel könnte zum Beispiel so aussehen:

Beispielbild zur Erläuterung von Formeln in Excel

In der Zelle C8 siehst du zum Beispiel den Stückpreis einer Banane, in der Nachbarzelle D8 die Anzahl, die der Kunde kaufen möchte. Natürlich könntest du jetzt schnell im Kopf 0,3 mit 5 multiplizieren und in die Zelle E8 schreiben. Wenn allerdings jemand 37 Bananen kaufen will hast du sicherlich keine Lust das im Kopf auszurechnen. Zum Glück kannst du dir diese Arbeit sparen, denn Excel bietet dir die Möglichkeit, alles automatisch ausrechnen zu lassen. Was soll also genau in der Zelle E8 stehen?
Du möchtest ja das Produkt aus Stückpreis und Anzahl der Bananen, uns interessiert also der Inhalt der Zelle C8 (Der Stückpreis einer Banane) und D8(Die Anzahl der gekauften Bananen).
Um einer Zelle einen automatischen Wert zuzuweisen, gibt es den Zuweisungsoperator "=". Der Inhalt der Zelle E8 soll nun gleich (also:"=") dem Inhalt der Zelle C8 multipliziert (also : "*") mit dem Inhalt der Zelle D8 sein. Unsere Eingabe für die Zelle E8 wäre also "=C8*D8".

Was ich dir hier beispielhaft an unserer Supermarktkasse gezeigt habe, kannst du natürlich auch in allen anderen Fällen machen. Beispielsweise wenn eine Zahl in einer Zelle A1 steht und du in einer anderen Zelle genau das doppelte des Inhaltes der Zelle A1 stehen haben möchtest, dann schreibst du einfach in die zweite Zelle "=2*A1". Natürlich kannst du auf diese Weise auch Zahlen addieren, subtrahieren und dividieren. Außerdem könnten es auch mehr als zwei Zellen sein, die addiert werden oder man könnte den Wert einer Zelle zur anderen addieren und dann durch den Wert einer dritten Zelle dividieren. Wichtig dabei ist nur, dass nach jeder Operation, also "+", "-" ,"*" oder "/" eine Zelle genannt wird. Ist dies nicht der Fall, so kommt es zu einem Fehler. Damit dir das nicht passiert, habe ich dir eine Grafik erstellt. Folgst du den Pfeilen immer bis zum "Return", dann kannst du beliebig viele Operationen aneinander hängen und es wird zu keinem Fehler kommen.

Grafik zu möglichen Zuweisungskombinationen
Relativer und absoluter Zellbezug

Kommen wir zurück zu unserem Supermarkt. Natürlich müssen wir nun die selbe Formel auch für die anderen Produkte eingeben. Aber bevor du das jetzt für jede Zelle einzeln und per Hand machst, zeige ich dir einen Trick.
Falls du dich schon immer einmal gefragt hast, warum da so ein kleiner schwarzer Kasten rechts unten ist, wenn du eine Zelle anklickst, dann kann ich dir nun die Erklärung dafür liefern. Klickst du zum Beispiel auf die Zelle E8 und dann auf das kleine Kästchen unten rechts und ziehst die Maus nach unten bis E19, so wird deine Formel aus E8 nach unten hin kopiert. Doch was passiert bei dem "herunterziehen" genau?

Schaubild zu relativen Zellbezügen

Wenn du nun die zweite Zelle unserer Rechnung anklickst, so wirst du feststellen, dass die Formel gar nicht 1:1 kopiert wurde, sondern die Zahlen hinter den Buchstaben alle um eins erhöht wurden Gehst du noch eine Zelle weiter herunter, so wurde die Zahl um zwei erhöht und so weiter. Dies nennt man relativer Zellbezug. Zieht man also die Formel eins nach unten, so werden alle Zahlen hinter den Buchstaben in der Ausgangsformel um eins erhöht, zieht man sie eins nach oben, dann werden die Zahlen dementsprechend um eins verringert und wenn du die Formel nach rechts ziehst, dann werden alle Buchstaben "um eins erhöht", also wird zum Beispiel aus einem "B" ein "C". Rechts im Schaubild kannst du noch einmal an einem Beispiel sehen, was sich beim "ziehen" in eine Richtung an den Formeln ändert.


Was macht man allerdings, wenn man zum Beispiel jede dieser Zellen noch mit einer Zahl multiplizieren möchte? Auch dieses Problem möchte ich dir anhand unseres Supermarkts näher bringen. Stell dir dafür einfach vor, dass jeder Kunde einen individuellen Rabatt zwischen einem und fünf Cent pro gekauftem Artikel bekommt, den der Mitarbeiter in ein zusätzliches Feld eingibt. Unsere Tabelle könnte nun zum Beispiel so aussehen:

Beispiel für relativen und absoluten Zellbezug

Nun soll unser "Kassensystem" nach dem Errechnen von Stückpreis mal Anzahl den in der Zelle F3 stehenden Rabatt abziehen. Und das bei jedem Artikel einzeln.

1. Was musst du nun in Zelle F8 als Formel eintragen?

C8*D8+F3
C8*D8-F3
C8*D8*F3
C8*D8/F3

Punkte: 0 / 0

Drücke auf "speichern" damit dir angezeigt wird, ob du richtig liegst.

Nachdem du die Formel für die Zelle E8 richtig eingegeben hast, könntest du nun wieder auf die Idee kommen, die Formel nach unten zu ziehen. Doch aufgepasst! Wird der Rabatt dann tatsächlich auch in der Zelle E9, E10, E11, ... abgezogen?
Wenn du dir die Formeln der einzelnen Zellen anschaust wirst du feststellen, dass dies nicht der Fall ist, da du ja wieder den relativen Zellbezug verwendet hast und sich somit die Zahlen beim herunterziehen immer um eins erhöht haben. Wenn dir das nicht sofort klar ist, so schaue dir noch einmal das Schaubild oben an. Wir wollen allerdings, dass sich die Zahl bei unserer Zelle F3 nicht beim herunterziehen verändert, denn genau dort steht unser Rabatt der für alle gleich ist. Dieser Bezug zu der Zelle nennt man absoluten Bezug und man erreicht ihn, wenn man statt "-E3" "-$E$3" eingibt. Beim herunterziehen wird dann die Zelle E3 nicht verändert, die anderen Teilstücke der Formel allerdings nach obigem Schema schon. Unsere Formel in E8 lautet also nun "C8*D8-$E$3". Wenn du nun noch einmal die Formel nach unten ziehst, stimmt dein Ergebnis wieder.

Die Summenformel

Nachdem wir unseren Kassenzettel nun soweit optimiert haben, dass wir nur noch die Zahlen die untereinander stehen aufsummieren müssen, kommen wir zu einer weiteren interessanten Formel. Natürlich kannst du jetzt berechtigterweise sagen, dass du keine neue Formel brauchst, weil du das Ergebnis auch mit dem gewöhnlichen Zuweisungsoperator ausrechnen kannst. Für unseren Fall sieht die Formel so aus:

                              =E8+E9+E10+E11+E12+E13+E14+E15+E16+E17+E18+E19 

Ziemlich lang oder? Und das waren erst 12 Artikel. In Excel gibt es die Möglichkeit, eine bestimmte Anzahl von Zahlen aufzusummieren, wenn sie in gewisser Weise angeordnet sind. Die "Summenformel" ist genau dann interessant, wenn man viele Zahlen aufsummieren möchte, die entweder alle untereinander (vgl. Abb. links), nebeneinander (vgl. Abb. in der Mitte) oder in Blockform (vgl. Abb. rechts) stehen.

Die 3 Möglichkeiten, um die Summenformel einzusetzen.

In unserer "Kassenzetteltabelle" steht in Zelle D21 "Gesamt". Daneben, also in Zelle E21, möchten wir alle darüber stehenden Kosten aufaddieren, denn das hat der Kunde letztlich zu bezahlen. Unsere Zahlen sind alle untereinander angeordnet, also schauen wir uns einmal genauer an, wie die Summenformel funktioniert. Beginnen musst du wie immer bei einer Zuweisung mit dem Zuweisungsoperator "=". Danach gibst du den Schlüsselbefehl "SUMME(" ein. Nun erwartet Excel von dir, dass du ihm angibst, welchen Bereich es aufsummieren soll. Hierfür musst du lediglich einen Start- und einen Endpunkt festlegen, die du mit dem Symbol ":" voneinander trennst. Danach musst du noch eine Klammer zu (also ")" ) schreiben. Excel weiß nun, dass es alle Zahlen in dem Bereich, der in den runden Klammern steht, aufsummieren soll. Schauen wir aber nochmal genauer hin, wie der Inhalt der Klammer bei den drei verschiedenen Typen aussieht:

1. Die Zahlen stehen in einer Reihe untereinander.
Für Excel heißt das also, dass die Zahlen alle in der selben Spalte stehen. Eine Aufsummierung der Zellen D10,D11,D12 würde also zum Beispiel so aussehen: =SUMME(D10:D12) . Excel erkennt, dass die Zellen D10 und D12, also unser Start- und Endpunkt in der selben Spalte, in unserem Fall die Spalte D, stehen und weiß somit automatisch, dass man Zahlen in einer Reihe untereinander aufsummieren möchte. Theoretisch könntest du statt "D10:D12" auch "D12:D10" schreiben, allerdings dreht Excel dann automatisch den Start- und Endpunkt um. Du kannst es ja mal ausprobieren.

2. Die Zahlen stehen in einer Reihe nebeneinander:
Für Excel heißt das also, dass die Zahlen alle in der selbe Zeile stehen. Zum Beispiel könnten wir die Zellen D10,E10,F10 aufsummieren. Im Vergleich zu 1. ist nicht die Spaltenbezeichnung gleich, sondern die Zeilenbezeichnung, in unserem Beispiel die Zeile 10. Um diese Zellen nun aufsummieren zu können geben wir also wieder Start- und Endpunkt an, in diesem Fall =SUMME(D10:F10). Excel erkennt, dass die Zeilenbezeichnung gleich ist und summiert vom Startpunkt aus nach rechts auf, bis der Endpunkt erreicht ist. Auch hier könnte man Start- und Endpunkt anders herum angeben, aber auch hier würde Excel die Einträge automatisch vertauschen, also aus "F10:D10" wieder "D10:F10" machen.

3. Die Zahlen stehen in einem Block angeordnet:
Während bei den ersten beiden Varianten entweder die Zeilen- oder Spaltenbezeichnung bei Start- und Endpunkt gleich war, ist dies bei der Aufsummierung von Zahlen in Blockform nicht der Fall. Möchte man also einen Block aufsummieren, so gibt man als Startpunkt die linke obere Zelle des Blocks an und als Endpunkt die rechte untere Zelle des Blocks.

Damit du die Summenformel perfekt anwenden kannst, habe ich wieder ein Quiz vorbereitet. Es zeigt dir auch Kombinationsmöglichkeiten. Es können auch mehrere Antwortmöglichkeiten richtig sein.

1. Den Inhalt welcher Zellen summiert man mit dem Befehl "=SUMME(F10:F12)" auf?

Die Zellen F10, G10, H10
Die Zellen F10, F11, F12
Die Zellen F10, G11, H12
Die Zellen F10 und F12

2. Den Inhalt welcher Zellen summiert man mit dem Befehl "=SUMME(A10:B11)" auf?

Die Zellen A10 und B11
Die Zellen A10, A11, B10, B11
Die Zellen A10, B10, A11, B11

3. Den Inhalt welcher Zellen summiert man mit dem Befehl "=SUMME(A10:C10)" auf?

Die Zellen A10 und C10
Die Zellen A10, A11, A12, A13
Die Zellen A10, B10 , C10

4. Den Inhalt welcher Zellen summiert man mit dem Befehl "=SUMME(A1:A2)+A3" auf?

Die Zellen A1, A2, A3
Die Zellen A1 und A2
Die Zellen A1, B1, A3

5. Den Inhalt welcher Zellen summiert man mit dem Befehl "=SUMME(A1:A2)+SUMME(B1:C1)" auf?

Die Zellen A1, A2, B1, C1
Die Zellen A1, B2, A2, B1
Die Zellen A1 und A2
Die Zellen B1 und C1

Punkte: 0 / 0


Hier die Erklärungen zu den Lösungen:
1.Die Spaltenbezeichnung ist gleich, wir befinden uns also im 1. Fall von oben, d.h. die Zahlen stehen untereinander. Startpunkt ist F10, danach kommt F11 und mit F12 ist der Endpunkt erreicht.
2.Weder Start- noch Endpunkt befinden sich in gleicher Spalte und Zeile, wir befinden uns im dritten Fall, dem Block. Achtung: Hier sind zwei Antworten richtig, nur in der Reihenfolge verdreht.
3.Die Zeilenbezeichnung ist gleich, wir befinden uns also im 2. Fall von oben, d.h. die Zahlen befinden sich nebeneinander. Vom Startpunkt A10 gehen wir nach rechts zu B10 und letztlich zu C10, dem Endpunkt.
4.Hier siehst du eine erste Kombinationsmöglichkeit von Formeln. Zunächst einmal wird die Summe von untereinander stehenden Zahlen gebildet, da die Spaltenbezeichnung gleich ist. Danach wird die Zelle A3 addiert. Übrigens: Man hätte diese Summe auch durch "=SUMME(A1:A3)" darstellen können.
5.Hier wurden zwei verschiedene Summenformeln verbunden. Die Erklärung für die richtige Lösung solltest du nun schon selbst geben können. Wichtig bei dem Beispiel war mir nur, dass du siehst, wie man Formeln kombinieren kann. Natürlich kannst du statt dem "+" auch einen anderen Operator verwenden.

Die Bedingung

Es gibt noch viele weitere Möglichkeiten, einer Zelle einen bestimmten Wert zuzuweisen. In diesem Abschnitt wollen wir uns mit der so gannten "Bedingung" auseinandersetzen. Überlegen wir uns dafür vielleicht erst einmal, was eine Bedingung in unserem Alltag bedeutet. Sicherlich kennt jeder die Aussage "Du darfst erst aufstehen, wenn alle fertig gegessen haben" oder "Du darfst erst zu deinem besten Freund gehen, wenn du deine Hausaufgaben gemacht hast". Bei der Beantwortung der Frage ob du aufstehen darfst, kommt es einzig und allein auf die Antwort auf die Frage "Sind alle mit dem Essen fertig?" an. Diese Frage ist also unsere Bedingung und hat zwei Antwortmöglichkeiten, nämlich "Ja", wenn alle fertig mit dem Essen sind und "Nein", wenn sie es eben nicht sind.
Wir wollen nun versuchen, dass unser Tabellendokument uns automatisch sagt, ob wir aufstehen dürfen oder nicht, wenn wir ihm die Information geben ob alle fertig mit dem Essen sind oder nicht, also die Bedingung beantworten. Auch für diese Situation habe ich dir ein Muster vorbereitet. Es könnte zum Beispiel so aussehen:

Beispiel für die Verwendung von einer Bedingung.

Wie du siehst, habe ich in Zelle C4 die Frage, die automatisch beantwortet werden soll, geschrieben. Darunter, also in Zelle C5 wird dann die Frage gestellt, deren Antwort für uns sehr wichtig ist, denn sie ist entscheidend dafür, ob wir aufstehen dürfen oder nicht.
Nun müssen wir der Zelle C7 einen Wert zuweisen. Doch wie kann ich jetzt einen Wert unter einer Bedingung zuweisen? Schauen wir uns dafür zunächst das folgende Schema an:

Beispielschema zur Veranschaulichung einer Bedingung

Was bedeutet das also für uns? In Zelle C7 soll "Du darfst aufstehen" stehen, wenn in C6 "Ja" steht, unsere Bedingung also wahr ist. Anderseits soll in der Zelle C7 "Du darfst nicht aufstehen" stehen, wenn unsere Bedingung nicht erfüllt ist, also in C6 "Nein" steht.
Wie auch bei allen anderen Formeln beginnen wir wieder mit dem Zuweisungssymbol "=", das wir in Zelle C7 schreiben. Nun erwartet das Programm wieder, dass ihm gesagt wird, was es genau zuweisen soll. In unserem Fall schreiben wir nun "WENN(". Als nächstes müssen wir die Bedingung eingeben. Wir erinnern uns: "Wenn in C6 "Ja" steht, dann soll in Zelle C7 "Du darfst aufstehen" stehen". Also ist unsere Bedingung in diesem Fall =WENN(C6="Ja". Als nächstes müssen wir ein ";" schreiben, denn dieses Symbol sagt aus, dass die Bedingung nun abgeschlossen ist und nun schreiben können, welchen Wert die Zelle C7 annehmen soll, wenn unsere Bedingung wahr ist, in unserem Fall schreiben wir also nun "Du darfst aufstehen". Erneut schreiben wir wieder das Symbol ";" und ergänzen nun abschließend noch, welchen Wert die Zelle C7 annehmen soll, wenn die Bedingung nicht wahr ist, hier also "Du darfst nicht aufstehen". Mit der Return-Taste schließen wir den Vorgang ab und siehe da, es funktioniert. Unsere Tabelle kann jetzt eigenständig Fragen beantworten.
Ebenso wie dieses Problem kannst du auch viele andere Problemstellungen mit der Bedingungszuweisung lösen. Ich habe dir im folgenden ein Quiz vorbereitet, dass dir weitere Möglichkeiten aufzeigt und gleichzeitig die Möglichkeit gibt zu überprüfen, ob du die allgemeine Vorgehensweise verstanden hast. Achte darauf, dass auch mehrere Antworten richtig sein können, denn sie zeigen dir verschiedene Herangehensweisen an ein Problem. Also los geht's !

1. Du befindest dich in Zelle R3 und möchtest, dass dort die Antwort auf die Frage "Ist die Zahl in der Zelle A4 größer als 0?" steht. Was schreibst du?

=WENN(A4>0;"Die Zahl ist positiv";"Die Zahl ist nicht positiv)
=WENN(A4>0;"Die Zahl ist nicht positiv"; "Die Zahl ist positiv")
=WENN(A4=5;"Die Zahl ist 5";"Die Zahl ist nicht fünf")
=WENN(A4<0;"Die Zahl ist nicht positiv";"Die Zahl ist positiv")

2. Du befindest dich in Zelle B3 und möchtest überprüfen, ob der eingegebene Pin-Code in Zelle E8 dem Code "109" entspricht oder falsch eingeben wurde.Was gibst du ein?

=WENN(B3=109;"Der Code ist korrekt";"Der Code ist nicht korrekt")
=WENN(E8=109;"Der Code ist nicht korrekt";"Der Code ist korrekt")
=WENN(E8=109;"Der Code ist korrekt";"Der Code ist nicht korrekt")
=WENN(B3>109;"Der Code ist größer als 109";"Der Code ist kleiner gleich 109")

3. Du befindest dich in Zelle A33 und möchtest, dass die größere der beiden Zahlen aus Zelle A1 und A2 in Zelle A33 geschrieben wird. Was schreibst du?

=WENN(A1>A2;A1;A2)
=WENN(A1>A2;A2;A1)
=WENN(A2>A1;A2;A1)
=WENN(A2>A1;A1;A2)

4. Und nun die abschließende Frage: Denkst du mit dem hier erlernten wissen kannst du ein Spiel "programmieren"?

Ja.
Nein.

Punkte: 0 / 0


Unser erstes Spiel: Tic Tac Toe

Wenn du bei der letzten Frage "nein" angekreuzt hast, dann wird es nun Zeit, dich vom Gegenteil zu überzeugen! Im Folgenden möchte ich dir erklären, wie du mit dem bis jetzt gelernten das Spiel Tic Tac Toe in Excel umsetzen kannst.
Natürlich muss man sich bei der Umsetzung einige Gedanken machen, aber damit du dir an dieser Stelle nicht den Kopf über die Lösung zerbrichst, werde ich sie dir Stück für Stück zeigen. Schaue dir dafür einfach das Video an. Wenn du willst, kannst du immer eine kleine Passage anschauen, dann auf Pause drücken und nachmachen.

Ich hoffe dir hat diese Selbstlerneinheit Spaß gemacht. Natürlich gibt es auch noch viele weitere Selbstlerneinheiten. Für eine Übersicht klicke einfach hier