ChemSketch

aus ZUM-Wiki, dem Wiki für Lehr- und Lerninhalte auf ZUM.de
Wechseln zu: Navigation, Suche
ChemSketch Programm zum Zeichnen 2- und 3-dimensionaler Strukturen, Reaktionsverläufe und Laboraufbauten und zur 3D-Visualisierung chemischer Strukturen.

Das Programm Chemsketch der Firma ACD Labs, aktuell in der Version 12 (November 2010), ermöglicht die Erstellung von Strukturformeln und Reaktionsgleichungen und von zwei- und dreidimensionalen Molekülstrukturen und deren Visualisierung am PC. Es erlaubt die Programmierung animierter 3D-Moleküle und die Berechnung der verschiedensten Parameter zu den gezeichneten Molekülen.

Das komplett englischsprachige Programm kann auf der Website des Herstellers herunter geladen werden und ist für Privatanwender und Bildungszwecke kostenlos (Lizenzbedingungen beachten!). Die Bedienung ist bei Vorhandensein chemischer Grundkenntnisse und mit Grundkenntnissen der englischen Sprache intuitiv möglich, die Hilfefunktion ist sehr ausführlich, so dass sich der interessierte Anwender die Möglichkeiten des Programms nach und nach erschließen kann.

Inhaltsverzeichnis

Einschränkungen der Freeware-Version

Die Freeware-Version weist einige Einschränkungen gegenüber der kommerziellen Vollversion auf. Einige sollen hier beispielgebend genannt werden, die Aufzählung erhebt jedoch keinen Anspruch auf Vollständigkeit:

  • Es gelingt mit der Freeware-Version durchaus, für gezeichnete Strukturformeln mit bis zu 50 Atomen und maximal trizyklischer Struktur (Einschränkung nur der Freeware-Version) die systematische Bezeichnung zu finden, der umgekehrte Weg - die Suche nach einer Struktur zu einem eingegebenen systematischen oder trivialen Namen (Handels- oder Trivialnamen werden in der Vollversion auch akzeptiert) - bleibt dem Verwender der Freeware-Version verschlossen.
  • Die Datenbankanwendung ACD/ChemFolder ermöglicht das Abspeichern tausender Strukturen, Reaktionsverläufe und Analysen sowie die Recherche innerhalb der Daten und die Erstellung grafischer Präsentationen und statistischer Analysen. Diese Anwendung ist in der Freeware-Version nicht verfügbar.
  • Der ACD/ChemCoder generiert und liest Barcodes zu chemischen Strukturen, ist in der Freeware-Version nicht verfügbar und für Privat- und Bildungszwecke auch weniger von Interesse.
  • ACD/Dictionary enthält über 30.000 Strukturen und 165.000 Namen und Synonyme chemischer Verbindungen. ACD/Dictionary steht in der Freeware-Version nicht zur Verfügung.

Lizenzbedingungen der Freeware-Version

Die Freeware-Version des Programms ist mit den genannten Einschränkungen für den privaten Gebrauch oder Bildungszwecke kostenlos nutzbar. [1]

Über das ChemSketch Educational Access Program (CEAP) [2] können Bildungseinrichtungen eine für die gesamte Bildungseinrichtung gültige kostenlose Lizenz erhalten. Über 300 Einrichtungen, darunter auch einige deutsche Bildungseinrichtungen, nutzen diese Möglichkeit.

Anforderungen

  • Win2000, XP, Vista, Win7
  • Größe der Installationsdatei: 39 MByte

Eine unter Linux lauffähige Version des Programms ist ebenfalls erhältlich, allerdings ist dies eine ältere Version. Die neueste Windows-Version kann aber auch unter Linux mit Hilfe von Wine genutzt werden. Allerdings funktioniert das Kopieren via Zwischenablage womöglich nicht (... nach meiner Erfahrung --~~)

Installation

Mit dem Download wird im Downloadverzeichnis des PC eine ausführbare Installationsdatei namens chemsk12_2010.exe gespeichert. Dies ermöglicht es, das Programm auch auf Rechnern ohne Internet-Anbindung zu installieren, etwa per USB-Stick.

Kurzanleitung

Nach dem Start zeigt das Programm eine Zeichenoberfläche ähnlich vieler Zeichenprogramme. Auf dieser Zeichenoberfläche können mit Hilfe der Werkzeugleisten am linken, oberen und rechten Bildschirmrand zunächst zweidimensionale Strukturformeln entworfen werden.


Nach dem Start befindet sich ChemSketch im "Structure"-Modus. Voreingestellt ist das Zeichnen einer Kohlenstoff-Kohlenstoff-Verbindung (C-C), der Austausch bereits gezeichneter C-Atome durch andere Elemente ist jedoch jederzeit möglich und Änderungen können jederzeit mit der "Undo"-Funktion widerrufen oder widerrufene Änderungen mit der "Redo"-Funktion wieder hergestellt werden. Beide Funktionen finden sich in der oberen "Edit"-Werkzeugleiste.

Bereits gezeichnete Strukturen sollten regelmäßig, auch bereits während des Zeichenprozesses, abgespeichert werden, um bei Computerabstürzen o.ä. nicht von vorn beginnen zu müssen. Zum Abspeichern empfiehlt sich das proprietäre programmeigene ".sk2"- Dateiformat, da aus diesem heraus alle anderen generiert werden können und die Struktur in diesem Dateiformat in jedem beliebigen Bearbeitungszustand gespeichert, ergänzt oder geändert werden kann.

Anwendungsbeispiel

Startbildschirm von ChemSketch12

Um die Arbeitsweise des Programms zu verdeutlichen und mit grundlegenden Funktionen vertraut zu machen, hier ein kleines Beispiel anhand folgender Aufgabe:

  • Zeichnen der Strukturformel eines Chlorophyll-A-Moleküls;
  • Herstellung einer druckreifen Vorlage im ".png"-Format mit einer Auflösung von 300 dpi;
  • Herstellung einer Animation zur Einbindung auf einer Website o.ä. mit einer animierten 3D-Darstellung des Chlorophyll-A-Moleküls.

Nach dem Start des Programms zeigt sich der rechts sichtbare Bildschirm.

Man bestätigt durch Klick auf "Ok", dass das Programm rein privat oder zu Bildungszwecken genutzt wird.

Anschließend befindet man sich auf der Zeichenoberfläche, auf der der Cursor "C---C" als Zeichen dafür anzeigt, eine Kohlenstoff-Kohlenstoff-Verbindung zu zeichnen.

Zeichnen eines Kohlenstoff-Grundgerüstes

Jetzt kann man sich (Weg 1) entscheiden, zunächst das Kohlenstoff-Grundgerüst des Moleküls ohne Rücksicht auf andere Atome zu zeichnen. Gezeichnete C-Atome können später einfach gegen andere Atome (beispielsweise N, S, P, O) ausgetauscht werden, indem man auf das entsprechende Atomsymbol in der Werkzeugleiste auf der linken Bildschirmseite klickt, den Cursorpfeil über dem zu substituierenden C-Atom positioniert (dadurch wird das entsprechende C-Atom mit einem rechteckigen Auswahlrahmen eingerahmt) und ein Klick in diesen Auswahlrahmen tauscht C gegen das vorausgewählte andere Element.

Diesen Weg verdeutlicht nebenstehendes Bild.

BildChemsk2.jpg
Hier ist der Porphinkopf des Chl A-Moleküls ohne Rücksicht auf die zentralen N-Atome (und noch ohne funktionelle Gruppen) gezeichnet, auf der rechten Seite des Porphinkopfes ist ein C-Atom angewählt und durch Auswahlrahmen hervor gehoben. Man sieht, dass das Programm entsprechend der Wertigkeit des Kohlenstoffs (und auch anderer Atome) und der Bindungsverhältnisse im Molekül (Einfach-, Doppel-, Dreifachbindung) die erforderlichen Wasserstoffatome (Hydrogens) einfach automatisch ergänzt bzw. anpaßt, so daß man sich beim Zeichnen um solche Details gar nicht mehr zu kümmern braucht. Auch die Sauberkeit des persönlichen Zeichenstils ist nicht so entscheidend, denn das Programm hält Funktionen bereit, die jeden Zeichner zu einem kleinen Picasso machen... was das Zeichnen von Molekülen angeht.

Oder man entscheidet sich (Weg 2), das Molekül von vornherein so zu zeichnen, wie es im Endeffekt aussehen soll, ebenfalls möglich, bedingt aber ein häufiges Klicken in die Werkzeugleiste am linken Bildschirmrand zur ständig neuen Auswahl von Atomen und ist u.U. deshalb etwas fehleranfälliger.

Zur Kontrolle des gezeichneten Moleküls bietet Chemsketch in der Infoleiste am unteren Bildschirmrand einen unschätzbaren Dienst: das Programm protokolliert das gezeichnete Molekül nicht nur während des gesamten Zeichenprozesses mit der Summenformel mit, sondern ermittelt bis zur zweiten Nachkommastelle exakt das Molgewicht "Formula Weight" (FW). So kann man schnell Zeichenfehler bis hin zu einer vergessenen Doppelbindung finden und ggf. korrigieren.

Einzeichnen beliebiger Elemente

Die Werkzeugleiste auf der linken Bildschirmseite hält zunächst eine begrenzte Auswahl verschiedener häufig benötigter Elemente zum "Zusammenbau" von Molekülen bereit, die man durch Klick auf das entsprechende Atomsymbol einfach auswählen kann. Es handelt sich dabei um die Elemente (in der dargestellten Reihenfolge von oben nach unten):

  • C ... Kohlenstoff (voreingestellt beim Programmstart)
  • H ... Wasserstoff
  • N ... Stickstoff
  • O ... Sauerstoff
  • F ... Fluor
  • Na ... Natrium
  • Si ... Silizium
  • P ... Phosphor
  • S ... Schwefel
  • Cl ... Chlor
  • K ... Kalium
  • Br ... Brom
  • Fe ... Eisen
  • Mg ... Magnesium
Sofern man das gesuchte Element in dieser einfachen Liste nicht findet, hilft ein Klick ganz oben in die Liste der linken Werkzeugleiste auf das Symbol:
Bild a.jpg
das eine Darstellung des Periodenystems öffnet, aus der jedes beliebige Element ausgewählt werden kann.

Zeichnen von Mehrfachbindungen und funktioneller Gruppen

Das Zeichnen von Mehrfachbindungen ist sehr einfach: den Cursorpfeil über dem entsprechenden Bindungsstrich positionieren, so daß dieser Bindungsstrich durch einen länglich-rechteckigen Auswahlrahmen hervor gehoben wird, einfacher Klick darauf macht aus der Einfachbindung eine Doppelbindung, ein weiterer Klick aus der Doppel- eine Dreifachbindung, weiterer Klick aus der Dreifach- wieder eine Einfachbindung usw.

Das Zeichnen funktioneller Gruppen gestaltet sich ähnlich einfach: will man einfache funktionelle Gruppen, wie beispielsweise Methyl- oder Hydroxyl-Gruppen ergänzen, genügt ein Klick in die linke Werkzeugleiste auf "C" (bei Methylgruppen) oder "O" (bei Hydroxylgruppen), terminales C-Atom anwählen (rechteckiger Auswahlrahmen), Linksklick, linke Maustaste gedrückt halten, Bindungsstrich herausziehen, Maustaste loslassen, fertig! Die notwendigen Wasserstoffatome für diese häufig vorkommenden Gruppen werden automatisch ergänzt.

Bei komplizierteren funktionellen Gruppen muß man diese nicht per Hand jedes mal neu zeichnen, sondern die rechte Werkzeugleiste hält selbst sowie nach Klick auf das Symbol "Table of Radicals" ganz oben in der rechten Werkzeugleiste eine große Auswahl von Zeichenvorlagen für häufig vorkommende funktionelle Gruppen, Moleküle und Teilmoleküle bereit. Nach kurzer Einarbeitungszeit ist das eine große Hilfe beim Zeichnen komplexerer Moleküle.

Die Auswahl des "Table of Radicals" umfaßt u.a.:

  • Kohlenstoffketten C3 bis C5;
  • Propyl-, Butyl-, Amylgruppen;
  • Kohlenstoffringe C3 bis C8;
  • funktionelle Kohlenstoff-, Stickstoff- und Schwefelhaltige Gruppen;
  • Aminosäuren;
  • "Protecting Groups".

Ein Auswahlklick auf eine dieser Gruppen erzeugt eine Schattenvorlage, die dem Mauszeiger folgt und auf die Zeichenvorlage gezogen und dort durch einen Mausklick positioniert werden kann. Anschließend kann man sie wie eine eigene Zeichnung weiter bearbeiten, beispielsweise ein C-Atom des Radikals (anklicken und linke Maustaste gedrückt halten) mit einem anderen C-Atom des selbst gezeichneten Moleküls (mit gedrückter linker Maustaste darüber positionieren, bis ein rechteckiger Auswahlrahmen über dem Atom angezeigt wird, Maustaste loslassen) verbinden. Eventuelle Unschönheiten bei diesem Zeichnungsstil verbessert das Programm nachträglich!

Zeichnen stereoskopischer Bindungen

Das Zeichnen stereoskopischer Bindungen wird dem Anwender ebenfalls sehr leicht gemacht: in der oberen Werkzeugleiste statt "Draw normal" einfach "Up stereo bonds" für nach vorn (zum Betrachter hin geneigte) Verbindungen anklicken, oder "Down stereo bonds" für vom Betrachter weg zeigende Verbindungen.

Zeichnen besonderer Bindungstypen

Die obere Werkzeugleiste hält zahlreiche weitere Möglichkeiten zum Zeichnen spezieller Bindungstypen bereit:

Porphinkopf des Chlorophyll b- Moleküls mit zentralem Mg-Atom und koordinativen Bindungen
  • Coordinating [Dashed] Bonds;
  • Undefined Stereo Bonds;
  • Solid Delocalization Curve;
  • Markush Bonds.

Durch Anklicken der kleinen Ecke rechts unten in den Icons ergeben sich weitere Möglichkeiten.

Nummerieren von Atomen

Auto Renumbering

Das Nummerieren von Atomen kann entweder automatisch durch das Programm erfolgen (Klick auf "Tools" --> "Auto Renumbering") oder man nutzt das komfortable Werkzeug zur manuellen Nummerierung von Atomen, das zudem die Möglichkeit bietet, vor und/oder nach der Nummer noch einen individuellen Text einzufügen, jederzeit die Nummerierung an beliebiger Stelle abzubrechen oder fortzusetzen.

Diese Möglichkeit erreicht man über die erweiterte Werkzeugleiste am linken Rand (gekennzeichnet durch zwei nach unten zeigende Pfeile) und Klick auf "#".

Das Löschen der Nummerierung gelingt über die obere Werkzeugleiste "Tools" --> "Clear Numbering".

Valenzen, Ladungen, Isotopen

Über die Funktion "Atom Chemical Properties" können folgende Eigenschaften von Atomen eingestellt bzw. verändert werden:

  • Valenzen;
  • Ladungen (diese können aber auch über die "Decrement/Increment"-Funktion geändert werden);
  • Isotopen des jeweiligen Elementes;

Zusätzlich kann das Atom noch mit Labels (Text, Zahlen) versehen werden, diese Funktion ähnelt dem manuellen Nummerieren von Atomen (siehe Abschnitt: Nummerieren von Atomen), wo ebenfalls vor und/oder nach der Nummer Texte eingefügt werden können.

Man erreicht die Funktion "Atom Chemical Properties" über die erweiterte Werkzeugleiste am linken Rand. Nach Anklicken des Buttons positioniert man den Cursor über dem zu bearbeitenden Atom und klickt es an. Darauf öffnet sich ein kleines Fenster, in dem die beschriebenen Bearbeitungen vorgenommen werden können. Nach Abschluß der Bearbeitung wird in der unteren Leiste ein Button erzeugt, in dem die veränderten Einstellungen zum Atom (z.B. ein Isotop) gespeichert werden). Man hat so jederzeit Zugriff auf seine bearbeiteten Atomeinstellungen. Es sind im Prinzip beliebig viele solcher Buttons generierbar, diese können jedoch auch durch einen Doppelklick in die untere Leiste wieder gelöscht werden.

Positionieren des Moleküls auf der Arbeitsoberfläche (Bewegen, Drehen, Spiegeln, 3D-Drehung)

Bereits der beim Programmstart voreingestellte "Structure"-Modus hält einige Möglichkeiten zur Positionierung und Veränderung der gezeichneten Struktur auf dem Arbeitsblatt bereit. Man kann aber jederzeit über das angezeigte Arbeitsblatt hinaus zeichnen, für große Moleküle reicht die A4-Seite ohnehin nicht aus.

Im "Structure"-Modus erreicht man in der oberen Werkzeugleiste die Funktionen "Select/Move", "Rotate" und "3D Rotation".

"Move"-Funktion: ein H-Atom des Adenosin-Moleküls ganz weit heraus gezogen. Der "Informative Cursor" zeigt die Verschiebungskoordinaten dx und dy an.
  • "Select/Move" wählt ein Atom zur Bearbeitung aus. Das Atom (mit den vom Programm automatisch ergänzten Hydrogens anklicken, Maustaste gedrückt halten und über die Zeichenfläche ziehen bewegt das Atom/ die Gruppe an die Stelle, wohin man sie haben will. Ist der "Informative Cursor" aktiviert, zeigt er die Koordinaten der Verschiebung an;
Das Adenosin-Molekül drehen: der "Informative Cursor" zeigt den Drehwinkel an.
  • "Rotate" Anklicken dieser Funktion aktiviert den Rotationsmodus für das ganze Molekül. Man faßt das Molekül durch einen Mausklick an irgend einem "Zipfelatom" an, hält die Maustaste gedrückt und kann das Molekül durch Mausbewegung beliebig in eine perspektivische Ansicht drehen; der "Informative Cursor" zeigt den Drehwinkel an;
  • 3D Rotation" Zweidimensional gezeichnete Strukturformeln lassen sich mit dieser Funktion dreidimensional in eine perspektivische Ansicht drehen. Button anklicken, "Zipfelatom" anfassen (Anklicken und Maustaste gedrückt halten) und einfach mal bewegen. Nach kurzer Einarbeitung hat man das Prinzip verstanden und kann es verwenden.

<wird fortgesetzt>

Suche tautomerer Formen

Die Suche nach tautomeren Formen der gezeichneten Strukturen gelingt mit einem Klick auf "Tools" --> "Check Tautomeric Forms".

Systematischer Name der Struktur

In der Freeware-Version kann das Programm für organische Verbindungen mit bis zu 50 Atomen und maximal 3 C-Ringen den systematischen Namen generieren. Das gelingt mit einem Klick in die erweiterte obere Werkzeugleiste (erreichbar über ">>") auf "Generate Name for Structure".

International Chemical Identifier (InChl)

Der International Chemical Identifier beschreibt molekulare Strukturen. ChemSketch kann den InChI-Code zu einer gezeichneten Struktur generieren (erreichbar über die erweiterte obere Werkzeugleiste nach Klick auf ">>", dann auf "InChI for Structure".

Den umgekehrten Weg kennt das Programm auch: es kann aus einem InChI-Code wieder eine Strukturformel erzeugen. Diese Option erreicht man über "Tools" --> "Generate" --> "Structure from InChI". Es öffnet sich ein kleines Fenster mit einem Texteingabefeld, in das per Hand oder per "copy and paste" der gewünschte InChI-Code eingefügt werden kann.

Nur am Rande sei erwähnt, daß das Programm eine weitere Form der Notation beherrscht (SMILES).

Recherche in Fachpublikationen

In der erweiterten oberen Werkzeugleiste (erreichbar über ">>" in der obersten Werkzeugleiste) erreicht man mit einem Klick auf "PubChem" [3], "eMolecules" [4] und "Chemspider" [5] diverse Fachpublikationen, zugeschnitten auf die in ChemSketch gerade bearbeiteten Moleküle und Strukturen, natürlich offen für weitere andere Recherchen in diesen Fachveröffentlichungen.

Für diese Funktion ist eine Internet-Anbindung des Rechners erforderlich, andernfalls reagiert das Programm mit einer Fehlermeldung.

Verbesserung der Zeichnung

Bisher ist das Molekül freihand gezeichnet und hat möglicherweise Verbesserungsbedarf. Man wählt zunächst das gesamte Molekül durch Klick auf "Edit"->"Select all" an. Eine Verbesserung der Molekülansicht gelingt dann zumeist durch Klick auf die Schaltfläche "Tools"->"Clean Objekt". Diese Funktion hält drei verschiedene Algorithmen bereit, nach denen das gezeichnete Molekül in optisch ansprechender Form präsentiert wird. Zum Durchlaufen der drei Algorithmen muß die Funktion ggf. dreimal nacheinander angeklickt werdenen, anschließend beginnt der Turnus von vorn.

Bei sehr komplexen Molekülen kann es u.U. einmal dazu kommen, daß man mit den drei angebotenen Darstellungsmodi nicht recht zufrieden ist, dann hilft es mitunter, das gezeichnete Molekül mit Hilfe der "Move"-Funktion etwas in die Form zu ziehen, die man gerne hätte (Einzelne Atome oder funktionelle Gruppen an die Position ziehen, die man bevorzugt).

Darstellungs- und Druckqualität

Nach dem Abspeichern von in ChemSketch gezeichneten Strukturen und Reaktionsgleichungen wird man beim Darstellen am Bildschirm, auf Webseiten usw. feststellen, daß die im Programm voreingestellte Auflösung von 96 dpi (dots per inch) zu niedrig ist; Bereits bei geringen Vergrößerungen sind Linien treppig, Schriften verwaschen. Dem kann man abhelfen, indem beim Abspeichern in einigen Grafikformaten, z.B. als Portable Network Graphics (Dateiendung: .png), TIFF Bitmap (Dateiendung: .tif) oder als Windows Bitmap (Dateiendung: .bmp) die Schaltfläche Save as" --> "Options" angeklickt wird (sie wird nur bei diesen Grafikformaten angeboten). Es öffnet sich ein kleines Fenster, in dem die gewünschte Auflösung in Stufen zwischen 96 und 720 dpi gewählt werden kann. Günstig sind Auflösungen von 300 oder 360 dpi für Darstellungen auf dem Bildschirm oder auf Webseiten oder für großflächige Ausdrucke. Noch höhere Auflösungen führen mitunter zu Schwierigkeiten mit anderen Programmen (z.B. Mediawiki).

Für die Einbindung in Webseiten, z.B. in wikis, kann man das Portable Network Graphics- Format verwenden. Mit Freeware-Programmen, wie beispielsweise Irfan View kann man jedoch alle genannten Formate ineinander umwandeln (allerdings nicht immer verlustlos).

3D-Darstellung des Moleküls

Nach der Generierung der Strukturformel ist eine Optimierung der Darstellung für den 3D-Modus erforderlich, hierbei werden Bindungswinkel entsprechend programmatischer Vorgaben ebenso berücksichtigt, wie die in der Strukturformel bisher nicht mitgezeichneten "Hydrogens" (Wasserstoff-Atome) ergänzt werden. Hierzu wählt man unter "Edit"->"Select all" das gesamte gezeichnete Molekül zur Bearbeitung aus, und wählt anschließend durch Klick unter "Tools"->"3D Optimization" die optimale 3D-Darstellung aus.

Das Anklicken der Funktion "3D Viewer" in der oberen Werkzeugleiste (erst erreichbar nach Klick auf die erweiterte Werkzeugleiste ">>") ergibt eine 3D-Ansicht des Moleküls, erst als farblich gestaltetes Fadenmolekül (Wireframe), doch die obere Werkzeugleiste hält die Möglichkeiten für Stäbchen (Sticks)-, Kügelchen und Stäbchen (Balls and Sticks)-, Kugel bzw. Kalotten (Spacefill)-, punkträumliche (Dots only) und scheibenförmig 2-dimensionale (Disks)- Darstellungen der Moleküle bereit, die zum Teil miteinander kombiniert werden können.

Mit einem Klick auf "Auto Rotate" in der oberen Werkzeugleiste kann man das Molekül am Bildschirm in eine zufallsgeneratorgesteuerte 3D-Rotation versetzen. Klick auf "Auto Rotate and Change Style" läßt das Molekül danach unabhängig vom einmal gewählten Darstellungsmodus (Wireframe, Sticks, Balls and Sticks usw.) nacheinander nach jeder vollen Umdrehung alle Darstellungsmodi durchlaufen, die das Programm parat hält.

Animationen aufnehmen und wiedergeben

Das fertige gezeichnete Chlorophyll A- Molekül in einer 3D- Darstellung (Balls and Sticks). Sehr schön kann man den Porphinkopf mit dem zentralen Mg-Atom (grau) und den lipophilen Phytolschweif erkennen, der die Ausrichtung des Moleküls innerhalb der pflanzlichen Zellorganellen, den Chloroplasten, ermöglicht.

Um ein animiertes 3D-Molekül zu generieren, sollte die gezeichnete Struktur zuerst mit der Funktion "Tools"->"3D-Optimization" in eine sinnvolle 3D-Darstellung umgewandelt werden. Die Funktion berücksichtigt sowohl programmäßig voreingestellte Bindungswinkel und ergänzt zudem die in der Strukturformel üblicherweise weggelassenen Wasserstoffatome (Hydrogens).

Anschließend kann das Molekül mit Hilfe des Programms "3D-Viewer" (erreichbar über die erweiterte obere Werkzeugleiste ">>"->"3D-Viewer") in einer 3D-Darstellung als Drahtmodell (Wireframe) dargestellt werden. Die Darstellung als Drahtmodell kann durch andere Darstellungsmodi, die die obere Werkzeugleiste dann im 3D-Viewer anbietet, abgelöst werden, und Klick auf "Auto-Rotate" versetzt das Molekül in zufallsgeneratorgesteuerte Drehung.

Jetzt kann man bereits auf diesem Wege eine kleine Animation aufnehmen, für die eine Rotation um die x-Achse voreingestellt ist. Dazu klickt man in der oberen Werkzeugleiste des 3D-Viewers ">>"->"Auto Add Frames" an, worauf sich ein kleines Fenster öffnet. Hier sind eine Rotation des Moleküls um 360° (ideal) und die Aufnahme von 20 Bildern pro Rotation (20 Frames) voreingestellt. Man kann das so belassen, aber aus Gründen der Darstellung ist zu empfehlen, eine höhere Frame-Rate zu wählen (50-90). Andernfalls wird die Darstellung zu ruckelig.

Mit Klick auf "Ok" in dem kleinen Fenster "Auto Add Frames" rotiert das Molekül einmal um die voreingestellte Achse und es werden die voreingestellte Anzahl von Bildern/Schnappschüssen (Frames) dieser Rotation aufgenommen. Anschließend kann das Filmchen unter "File"->"Save As" als "Animated GIF Image" (.gif) abgespeichert werden. In diesem Format, das von fast allen Programmen bedient wird, kann man die kleine Animation in Dokumente, Websites usw. einbinden oder weiter geben.

Darüber hinaus sind jedoch auch weitere Möglichkeiten der Steuerung der Animation vorhanden.

<wird fortgesetzt>

Beispiele

α-Amanitin, das Gift des Knollenblätterpilzes. Das Molekül besteht aus einem bizyklischen Peptidring aus 8 Aminosäuren, der durch eine Schwefelbrücke geteilt und stabilisiert wird.

Als Beispiel für die Moleküldarstellung sieht man hier das bizyklische Oktapeptid α-Amanitin, das hauptsächlich für die Giftigkeit der Knollenblätterpilze (Grüner Knollenblätterpilz (Amanita phalloides), Frühlingsknollenblätterpilz oder Weißer Knollenblätterpilz (Amanita verna) und des Kegelhütigen Knollenblätterpilzes (Amanita virosa) verantwortlich ist.

Durch das gelbe S-Atom deutlich sichtbar die Schwefelbrücke, die den Ring aus acht Aminosäuren in zwei Teile teilt und das Molekül so stabil macht, das es durch Erhitzen und Verdauungsenzyme nicht angegriffen wird.


Die nebenstehende Animation wurde aus einer ChemSketch-Animation mit Hilfe der ebenfalls als Freeware erhältlichen Programme Irfan View und UnFreez erstellt. Ausgangspunkt war eine in ChemSketch erstellte Animation eines Tartrolon-B- Moleküls (Cytotoxin aus marinen Aktinomyceten, Gruppe von Antitumor-Wirkstoffen). Um die zwei Sauerstoff-Sauerstoff-Brücken im Molekül hervor zu heben, wurden zwei 360°-Umläufe des Moleküls mit je 30 Einzelbildern (Frames) aufgenommen, einmal in der normalen Farbgestaltung (Sauerstoff rot) und einmal die zwei -O-O- Brücken hellgrün hervorgehoben.

Ein Tartrolon-B-Molekül mit zwei Sauerstoff-Sauerstoffbrücken (-O-O-). Die 6 Sekunden dauernde Animation wurde aus einer Chemsketch-Animation erzeugt, die mit zwei ebenfalls als Freeware erhältlichen Programmen nachbearbeitet wurde.

Die einzelnen Frames wurden mit Irfan View extrahiert, mit den beiden Alternativtexten versehen (Panoramabildfunktion von Irfan View) und in anderer Reihenfolge zusammengesetzt (erstes Bild der ersten Umdrehung, erstes Bild der zweiten Umdrehung...). Durch den Wechsel der Atomfarben von Rot nach Hellgrün alle 0,1 s ergibt sich der visuelle Eindruck, dass die Atome "blinken".

Linkliste